本站提供互联网编程技术交流分享,部分技术教程不断更新中,请随时关注或联系我寻求帮助 有事点我吧同时也欢迎有兴趣的朋友进行投稿。

wordpress阿里云提示漏洞修复,wordpress后台插件更新模块任意目录遍历导致DOS漏洞

WP教程 熊哥club 443℃ 1评论

无意之间发现club域名居然能备案了,为了访问速度,刚把博客从aws迁移到阿里云。所有文件拷贝过来后,就收到如下云盾提示的漏洞信息

漏洞描述

wordpress后台文件/wp-admin/includes/ajax-actions.php中,对代码插件路径的输入参数plugin未进行正确的规范化转义,导致黑客可传入特殊路径,造成拒绝服务。【注意:该补丁为云盾自研代码修复方案,云盾会根据您当前代码是否符合云盾自研的修复模式进行检测,如果您自行采取了底层/框架统一修复、或者使用了其他的修复方案,可能会导致您虽然已经修复了改漏洞,云盾依然报告存在漏洞,遇到该情况可选择忽略该漏洞提示】

网上google一些,据说直接把wordpress升级到最新版本就可以了。果断升级

升级后,立即验证。貌似修复了

由于时间问题,另外两个漏洞有空再研究。

阿里云提示Discuz uc.key泄露导致代码注入漏洞uc.php的解决方法

适用所有用UC整合

阿里云提示漏洞:

 

漏洞名称:Discuz uc.key泄露导致代码注入漏洞
补丁文件:/api/uc.php

补丁来源:云盾自研

 

解决方法:
找到文件/api/uc.php​ 中的以下代码:

大概216行,替换成以下:

更新代码后,在阿里云后台这条漏洞后面点“验证一下”,即可看到这条漏洞补上就没有了

漏动来源:阿里云云盾

漏动名称:Didcuz memcache+ssrf GETSHELL漏洞

漏动描述:Discuz存在SSRF漏洞,在配置了memcache的情况下,攻击者可以利用ssrf通过memcache中转,向磁盘上写入WEBSHELL恶意代码,从而造成数据库泄漏;

漏动文件:/source/function/function_core.PHP

修复方法:

查找位置:

修改完,上传替换原文件。​

本文地址: http://www.xiongge.club/1007.html

转载请注明:熊哥club » wordpress阿里云提示漏洞修复,wordpress后台插件更新模块任意目录遍历导致DOS漏洞

喜欢 (1)
[您的支持是我最大的动力]
分享 (0)
发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
(1)个小伙伴在吐槽
  1. 升级就好了。
    啦啦2017-02-16 17:17 回复
×
订阅图标按钮